DynDNS ο τσάμπας πέθανε ;)
Re: DynDNS ο τσάμπας πέθανε ;)
Εβαλα το afraid.org που έχει και εύκολο τρόπο να αναναιώνεται απο το mikrotik.
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
Re: DynDNS ο τσάμπας πέθανε ;)
Για το mikrotik που είναι χωρίς nat:
# Set needed variables
Για NAT:
# Set needed variables
Code: Select all
:local hostname neoplan.pwmn.net
:global interfacename OTE
:global previousIP
# get the current IP address from the interface
:global currentipadd [/ip address get [/ip address find interface=$interfacename] address]
:global currentIP [:pick $currentipadd 0 [:find $currentipadd "/"]];
#:log info "CurrentIP: = $currentIP"
:if ($currentIP != $previousIP) do={
:set previousIP $currentIP
/tool fetch \
mode=http \
address="freedns.afraid.org" \
host="freedns.afraid.org" \
src-path="dynamic/update.php\?key_here" \
keep-result=no
:log info ("AfraidDNS: Updated")
} else={
#:log info ("AfraidDNS: No update needed")
}
Code: Select all
# Set needed variables
:local hostname neokal.pwmn.net
:global previousIP
:global currentIP
# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]
# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:set currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"
:if ($currentIP != $previousIP) do={
:set previousIP $currentIP
/tool fetch \
mode=http \
address="freedns.afraid.org" \
host="freedns.afraid.org" \
src-path="dynamic/update.php\?key_here" \
keep-result=no
:log info ("AfraidDNS: Updated")
} else={
:log info ("AfraidDNS: No update needed")
}
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
- Itmy
- AMD Athlon
- Posts: 893
- Joined: Thu Mar 08, 2007 12:17 am
- PWMN Wind Node ID: 108
- Location: Itmy Territory
- Contact:
Re: DynDNS ο τσάμπας πέθανε ;)
Χμμμ να υποθέσω ότι το password μπαίνει στο key_here ?
Επίσης το hostname δε βλέπω να το χρησιμοποιεί το script.
Επίσης το hostname δε βλέπω να το χρησιμοποιεί το script.
Death to all Fanatics
- Itmy
- AMD Athlon
- Posts: 893
- Joined: Thu Mar 08, 2007 12:17 am
- PWMN Wind Node ID: 108
- Location: Itmy Territory
- Contact:
Re: DynDNS ο τσάμπας πέθανε ;)
Α σα να καταλαβα τι είναι. Δε χρειαζεται user/pass αλλά το key που φαίνεται στο link "Direct URL" όταν πας να κάνεις ανανέωση της IP του subdomain από τη σελίδα.
Είναι κάτι τέτοιο:
http://freedns.afraid.org/dynamic/updat ... w890blabla![Very Happy :D](./images/smilies/icon_biggrin.gif)
Είναι κάτι τέτοιο:
http://freedns.afraid.org/dynamic/updat ... w890blabla
![Very Happy :D](./images/smilies/icon_biggrin.gif)
Death to all Fanatics
Re: DynDNS ο τσάμπας πέθανε ;)
Ναι, το hostname μου είχε ξεμείνει από το dynDNS.org
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn
- Itmy
- AMD Athlon
- Posts: 893
- Joined: Thu Mar 08, 2007 12:17 am
- PWMN Wind Node ID: 108
- Location: Itmy Territory
- Contact:
Re: DynDNS ο τσάμπας πέθανε ;)
Έβαλα τα scripts εδώ να υπάρχουν
http://www.pwmn.net/wiki/index.php/DDNS#NAT
http://www.pwmn.net/wiki/index.php/DDNS#NAT
Death to all Fanatics